on arch with latest package versions 4get (latest commit) throws this error when querying with external client:
2025/07/11 22:18:01 [error] 2350082#2350082: *1 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Call to undefined function apcu_inc() in /var/www/4get/lib/bot_protection.php:10
Stack trace:
#0 /var/www/4get/web.php(19): bot_protection->__construct()
#1 {main}
thrown in /var/www/4get/lib/bot_protection.php on line 10" while reading response header from upstream, client: redacted, server: redacted, request: "GET /web?s=apcu_inc() HTTP/2.0", upstream: "fastcgi://unix:/run/php-fpm/php-fpm.sock:", host: "redacted"
on arch with latest package versions 4get (latest commit) throws this error when querying with external client:
```
2025/07/11 22:18:01 [error] 2350082#2350082: *1 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Call to undefined function apcu_inc() in /var/www/4get/lib/bot_protection.php:10
Stack trace:
#0 /var/www/4get/web.php(19): bot_protection->__construct()
#1 {main}
thrown in /var/www/4get/lib/bot_protection.php on line 10" while reading response header from upstream, client: redacted, server: redacted, request: "GET /web?s=apcu_inc() HTTP/2.0", upstream: "fastcgi://unix:/run/php-fpm/php-fpm.sock:", host: "redacted"
```
funnily enough, im currently running my instance from docker and it works fine
> My god this docker shit sucks so much
>
> The apcu package probably got obsoleted again
funnily enough, im currently running my instance from docker and it works fine
Well it's complaining about APCU not being present. Run
php -i "phpinfo();" | grep apcu
If nothing gets outputted, PHP isn't compiled/bundled with apcu
If it's not present, install apcu with your package manager and restart your webserver
Well it's complaining about APCU not being present. Run
```
php -i "phpinfo();" | grep apcu
```
If nothing gets outputted, PHP isn't compiled/bundled with apcu
If it's not present, install apcu with your package manager and restart your webserver
theres something. given that php-acpu is in main repo, dont think it got obsolete
```
php -i "phpinfo();" | grep apcu
Additional .ini files parsed => /etc/php/conf.d/apcu.ini,
```
theres something. given that php-acpu is in main repo, dont think it got obsolete
ok, my bad - it needed apc.enable_cli=1 config setting to show up in cli.
also the arch deps in the documentations have to be updated, since arch also requires php-sodium to make 4get work.
thank you for taking your time on resoling this issue
ok, my bad - it needed apc.enable_cli=1 config setting to show up in cli.
also the arch deps in the documentations have to be updated, since arch also requires php-sodium to make 4get work.
thank you for taking your time on resoling this issue
Blocking a user prevents them from interacting with repositories, such as opening or commenting on pull requests or issues. Learn more about blocking a user.
on arch with latest package versions 4get (latest commit) throws this error when querying with external client:
My god this docker shit sucks so much
The apcu package probably got obsoleted again
funnily enough, im currently running my instance from docker and it works fine
Well it's complaining about APCU not being present. Run
If nothing gets outputted, PHP isn't compiled/bundled with apcu
If it's not present, install apcu with your package manager and restart your webserver
theres something. given that php-acpu is in main repo, dont think it got obsolete
Sorry, didn't notice grep was case sensitive
oh yeah, now theres nothing in output. guess ill have to stick with docker image...
https://wiki.archlinux.org/title/PHP
Ctrl+F
apcu.iniyeah even with enabling it in the config apcu support is disabled
are you sure
php-apcupackage is installed and that you restarted your PHP-FPM processes?yep, installed and restarted - is disabled
ok, my bad - it needed apc.enable_cli=1 config setting to show up in cli.
also the arch deps in the documentations have to be updated, since arch also requires php-sodium to make 4get work.
thank you for taking your time on resoling this issue